Índice del Foro EliteFreak.net EliteFreak.net
Los foros de EliteFreak
 
 F.A.Q.F.A.Q.   BuscarBuscar   Lista de MiembrosLista de Miembros   Grupos de UsuariosGrupos de Usuarios   RegístreseRegístrese 
 PerfilPerfil   Conéctese para revisar sus mensajesConéctese para revisar sus mensajes   ConectarseConectarse 

Problema audio con divx elitefreak en la ps3

 
Publicar Nuevo Tema   Responder al Tema    Índice del Foro EliteFreak.net -> Audio y Video
Ver tema anterior :: Ver siguiente tema  
Autor Mensaje
jordicm
Acabo de llegar


Registrado: 20 Feb 2010
Mensajes: 4

MensajePublicado: Sab 20-Feb-2010 23:17    Título del mensaje: Problema audio con divx elitefreak en la ps3 Responder citando

Hola a todos,

desde hace mucho tiempo he visto sin problemas películas de eliteFreak en la ps3.

Pero desde hace unas semanas hay algunas que al reproducirlas no se escucha el sonido. Parece ser que la Play sólo ve un canal de audio sin sonido.

Creo que sólo me ha pasado con algunas películas con sonido AC3. Antes nunca había dado problemas el AC3.

Por ejemplo, la película Moon recién publicada, no puedo escucharla en la ps3.

Las películas están bien bajadas porque las escucho perfectamente con VLC o mplayer. Tengo una ps3 slim con el fw 3.15.

Alguna idea de qué puede estar pasando?

Muchas gracias.
Volver arriba
Ver perfil del usuario Enviar mensaje privado
spider1
FreAk ADiCto


Registrado: 23 Oct 2007
Mensajes: 1778

MensajePublicado: Dom 21-Feb-2010 00:27    Título del mensaje: Responder citando

Problemas con ficheros de vídeo con el audio en AC3
Sin embargo, yo he encontrado problemas con bastantes ficheros AVI con el audio comprimido en AC3 (por lo que se ve en los foros, parece que esto les ocurre bastante a otras personas), en los que la pista de audio simplemente ni se oía ni era correctamente detectada. Por ejemplo, vemos que al mostrar información sobre el archivo (botón SELECT), dice que el audio es “Dolby Digital 1 C. 32kHz” cuando debería detectar “Dolby Digital 5.1 C. 48kHz”.

Curiosamente, en películas cortadas en dos pedazos (por ejemplo, “Película parte 1.avi” y “Película parte 2.avi“), el audio del primer pedazo no se oye bien y el del segundo pedazo, sí. Y si le quitas unos segundos a la película por delante con VirtualDub o VirtualDubMod (si la película tiene varios streams), el problema también parece desaparecer. Esto indicaría algún problema con los primeros bytes de la pista de audio AC3.

Buscando, buscando, encontré las páginas problems with xvid with ac35.1 in ps3 y Muxing AC3 with delay into an AVI con las que aprendí que el problema es que:

PS3 can’t play audio with delay at VirtualDub style: garbage until the first valid header.

Es decir, que hay ciertos programas que almacenan el AC3 dentro del AVI con datos inválidos hasta la primera cabecera válida, lo que causa que la PS3 no detecte la pista correctamente.

Así, descubrí que sólo con reprocesar tales ficheros AVI con el programa para Windows de código abierto AVI-Mux GUI (tarea muy sencilla que apenas lleva unos pocos minutos y no conlleva ninguna pérdida de calidad), la pista de audio ya se multiplexa correctamente y la película ya se puede ver a la perfección en la PS3.


Es la experiencia de un usuario de PS3 y funciona

Un saludo
Volver arriba
Ver perfil del usuario Enviar mensaje privado
jordicm
Acabo de llegar


Registrado: 20 Feb 2010
Mensajes: 4

MensajePublicado: Dom 21-Feb-2010 01:20    Título del mensaje: Responder citando

Sí, parece que has dado en el clavo. He encontrado el hilo en doom9 donde explican el problema.

Me pregunto: ¿no podrían en EliteFreak generar los archivos con AC3 con las opciones que comentan en este otro hilo?
http://forum.doom9.org/showthread.php?t=146268

Supongo que este problema le ha de pasar a todo el mundo que vea los xvid con ac3 de EliteFreak en la ps3.

Ahora a ver si de momento me puedo hacer esos arreglos en Linux...
Volver arriba
Ver perfil del usuario Enviar mensaje privado
spider1
FreAk ADiCto


Registrado: 23 Oct 2007
Mensajes: 1778

MensajePublicado: Dom 21-Feb-2010 03:34    Título del mensaje: Responder citando

Basta con cortar 2 segundos al principio y al final de la peli.

Un saludo
Volver arriba
Ver perfil del usuario Enviar mensaje privado
Mostrar mensajes anteriores:   
Publicar Nuevo Tema   Responder al Tema    Índice del Foro EliteFreak.net -> Audio y Video Todas las horas están en GMT + 1 Hora
Página 1 de 1

 
Saltar a:  
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas


Powered by phpBB © 2001, 2005 phpBB Group

elitefreak © 2003, 2008 FreAk TEAm